iSuite™

Hola y bienvenidos a iSuite™, un conjunto de programas que permiten al usuario poder realizar prácticamente cualquier diagnóstico de su conexión a internet, así como obtener cualquier tipo de información relacionada con su conexión a internet. iSuite™ es el sucesor de BASpeed™, creado por su mismo creador, djnacho (José Ignacio Legido), usuario y moderador de varios foros en bandaancha.eu

La suite de programas es muy amplia, y abarca muchos aspectos de su conexión a internet (test de velocidad descarga / subida, medición de latencias, ver la ruta que sigue un paquete de información hasta un servidor, información sobre la central telefónica que nos da servicio físicamente (ADSL), etc).

Para que el usuario pueda encontrar rápidamente cualquier programa de la suite que necesite, los programas han sido clasificados y ordenados según varias categorías, visibles desde la ventana principal del programa, o bien desde el menú contextual del icono del programa presente en la bandeja del sistema de Windows.

En los siguientes capítulos de la ayuda, podrá encontrar toda la información que necesite para aprender a manejar cualquier programa incluido en iSuite™, y comprender la información devuelta por aquellos programas de iSuite™ que muestren información de la conexión al usuario.


tests

Tests de la conexión a internet

En esta categoría se incluyen todos los programas que han sido creados para realizar algún tipo de test a la conexión a internet. Cuando nos referimos a tests, nos referimos a pruebas que el usuario ordena que se ejecuten sobre su conexión a internet, obteniendo una serie de resultados que le informan del estado de su conexión.

En iSuite™ se incluyen en esta categoría los siguientes programas:

Lista de programas de la categoría Tests
  • Test de velocidad de descarga / subida (iSpeed™)
  • Test de medición de latencia (ping) e información de la ruta de los paquetes de información (tracert) (iPTracert™)
iSuite


Test de velocidad de descarga / subida

Test de velocidad de descarga / subida (iSpeed™)

Este es el programa más "mimado" de todos los que componen iSuite™. Toda la aventura que comenzó con el programa ONOSpeed y continuó con la suite BASpeed™, tiene su origen en un test de velocidad de descarga / subida. A partir de este programa, se fueron uniendo con el tiempo muchos otros hasta conformar lo que hoy es iSuite™.

El objetivo principal del test de velocidad, es poder ejecutar un test de velocidad en la conexión a internet del usuario, y poder mostrar en tiempo real, la velocidad media mantenida por la conexión. Este dato es muy importante a la hora de comenzar a diagnosticar la conexión, ya que si hay algún tipo de problema con la conexión, una de las primeras cosas que pueden ir mal es la velocidad de descarga o subida.

Hay tres zonas distintas en la ventana del programa:

Zonas de la ventana del test de velocidad
  • Medidor analógico de velocidad
  • Medidor de progreso del test de velocidad
  • Selección del tipo de test de velocidad

Medidor analógico de velocidad

Esta es una captura del medidor analógico de velocidad del test de velocidad de iSuite™:

Como se puede ver en la imagen, es un medidor de velocidad muy parecido al que puede encontrarse en cualquier automóvil. Los números que contiene (10,20, etc), son los Megabits por segundo que es capaz de medir el test de velocidad. Como se puede observar, la máxima velocidad que puede medir este medidor es de 100 Megabits por segundo (abreviado como 100 Mbps).

Aunque no es la máxima velocidad que el test puede medir. La máxima velocidad que puede medir el test son 2^64 bps, lo cual supone un total de 18.446.744.073.709.551.616 bps, o bien 18.446.744.073.709.551,616 Mbps o bien 18.446.744.073.709,551616 Gbps o bien 18.446.744.073,709551616 Tbps. En definitiva es una burrada de velocidad, que es casi imposible de medir actualmente, pero que el programa ya está preparado para medir esas velocidades gigantescas si hiciese falta.

Los números que se muestran abajo con dos decimales (000.00) indican la misma velocidad que muestra el medidor analógico, pero en forma de texto. Ofrece la velocidad, en Megabits por segundo (mbps) al igual que el medidor analógico. Los datos del medidor analógico se actualizan cada 1/4 de segundo (250 milisegundos). La velocidad que ofrece este medidor es la velocidad media mantenida por la conexión (ya sea en descarga o en subida).

Los colores que aparecen en la parte externa del medidor (va del rojo al verde pasando por amarillo y verde oscuro) hacen una referencia visual a la velocidad que está midiendo el test. Para el test de velocidad, de 0 a 5 Mbps va en color rojo, de 5 a 10 Mbps va en color amarillo, de 10 a 30 va en verde oscuro, y de 30 a 100 va en color verde claro. De esa forma se distingue claramente y de forma visual las distintas variaciones de velocidad en la conexión.

Información importante
Si la velocidad sobrepasa los 100 Mbps, el medidor analógico (velocímetro) no marcará más de 100 Mbps. El indicador numérico si se actualizará con la velocidad correcta. Esto se hace así, debido a que la mayoría de las conexiones actuales no sobrepasan los 100 Mbps. En caso de que en algún momento, las conexiones de los operadores sobrepasaran los 100 Mbps, el programa se actualizaría para recoger dicha subida.

Medidor de progreso del test de velocidad

Esta es una captura de la barra de progreso del test de velocidad de iSuite™

Aquí podeis ver la barra de progreso del test de velocidad de iSuite™. Esta barra marca el progreso del test de velocidad, y por lo tanto indica al usuario la "cantidad" del test de velocidad que se ha realizado. El test finaliza, cuando el progreso del test de velocidad llegue al 100%, sea cual sea el test de velocidad escogido. Esta barra se actualiza al mismo ritmo que el medidor analógico de velocidad.

Selección del tipo de test de velocidad

Esta es una captura de los botones que nos permiten cambiar el tipo de test de velocidad en iSuite™:

Aquí se pueden ver los dos botones con los que el usuario puede elegir el tipo de test de velocidad que desea realizar sobre su conexión a internet.

El test automático permite al programa elegir entre tres tests distintos dependiendo de la latencia que la conexión tenga sobre los servidores (los tests son los de ONO, bandaancha.eu y SoloGigabit SL).
Si el usuario pulsa el botón de Elegir Test, el programa muestra una lista con 6 servidores distintos (tres de los servidores son españoles, y los otros tres extranjeros, dos de ellos de la unión europea, y otro de Estados Unidos).
Se han distribuido de esa manera los tests de velocidad, para que el usuario pueda hacer pruebas a distintas distancias, de menor (en España) a mayor (en Estados Unidos).

tests


Test de Ping / Tracert

Test de Ping / Tracert (iPTracert™)

iPTracert™, es el programa que ha fusionado dos programas que funcionaban por separado en BASpeed™. Anteriormente, existía el programa de medición de latencias (ping) y otro programa aparte que se encargaba de informar al usuario de la ruta que toma un paquete para llegar a un determinado equipo en internet (tracert).
iPTracert™ ha unido los dos programas que funcionaban por separado en uno sólo, de forma que las funciones y controles visuales de ambos programas comparten la misma ventana.

El funcionamiento del programa es muy sencillo, y se realiza en tres sencillos pasos, que son los siguientes:

Funcionamiento del programa iPTracert™
  • Seleccionar el tipo de test que el usuario desea realizar (ping o tracert)
  • Indicar el equipo destino del cual se quiere saber la latencia (ping) o ver la ruta de la información (tracert)
  • Realizar el test y ver el resultado

Seleccionar el tipo de test (ping o tracert)

El programa necesita saber que tipo de test desea realizar el usuario, ya que la información varia de un test a otro. Aquí hay una captura de pantalla de la zona de selección del tipo de test:

Como se puede comprobar la elección es de lo más sencilla posible. Sólo hay dos posibles elecciones y sólo puede elegirse una al mismo tiempo.
La primera (ping) permite realizar un test de latencia. Esto quiere decir que el programa envía una serie de paquetes especiales al equipo destino, y mide el tiempo que estos paquetes tardan en ir y volver de dicho equipo. Ese tiempo es lo que se denomina latencia (o ping), y cuanto menor sea, mejor será la conexión y más rápido responderá la conexión. En el caso de seleccionar la segunda opción, el programa lanzará paquetes al equipo destino, pero al mismo tiempo informará al usuario de que equipos intermedios está atravesando la información antes de llegar al equipo destino.

Se puede especificar el número de paquetes que se mandan al equipo destino (si se selecciona el test de ping), mediante una lista de selección, cuya captura de pantalla es esta:

Si se selecciona el test de tracert, se puede especificar el número de saltos (equipos intermedios) máximo que el programa puede realizar antes de parar el test de tracert. Una captura de pantalla de esa lista de selección:

Indicar el equipo destino

Una captura de pantalla de zona donde el usuario puede especificar el equipo de internet del cual quiere saber la latencia o bien la ruta:

Información importante
El usuario, tanto para medir pings como realizar tracerts, debe escribir en esta zona únicamente el dominio del equipo al cual queremos acceder.
Un ejemplo: Si queremos saber la latencia a http://bandaancha.eu, tenemos que escribir en la zona antes descrita bandaancha.eu (sin http://)

Realizar test y ver el resultado

Una vez que se ha seleccionado el tipo de test, y en su caso el número de pings máximo o el número de saltos máximo (en caso de un tracert), debemos pulsar el botón Iniciar Test.
Una vez pulsado ese botón, los resultados del test de ping o el test de tracert (según la elección del usuario) se irán presentando en tiempo real en la zona de datos del programa destinada a tal fin.
En la siguiente captura de pantalla, el usuario puede observar el dominio introducido en la zona para indicar el equipo destino, y el resultado de un test de ping realizado a dicho dominio. Se puede observar el número de ping realizado, la IP del dominio en cada ping y la latencia al dominio en cada ping.

Información importante
Si en vez de un test de ping, se hubiera realizado un test de tracert, la zona de datos sería distinta, habiendo una primera columna para indicar el número de salto, una segunda columna con la IP del equipo intermedio en dicho salto, y tres columnas más, cada una de ellas con una medición de latencia sobre dicho equipo intermedio.
Tests de la conexión